Google SSO - Partially Degraded Service

Incident Report for Archive

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 16:27 UTC

Update

Issue is resolved
Posted Jul 18, 2025 - 16:26 UTC

Update

Google has fixed the issue impacting authentication and Google SSO is now functioning again.
Posted Jul 18, 2025 - 16:25 UTC

Identified

There is an external issue with Google's authentication service that is preventing a subset of users from logging in via SSO. This is a broader issue that is affecting services other than Archive as well.

Email/password authentication still works. We're monitoring the scope and waiting on the broader fix by Google.
Posted Jul 18, 2025 - 15:46 UTC
This incident affected: Archive Platform.